Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
Mottie (MVP) 2/21/2009 10:18 AM EST : Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Adding an Allakhazam tooltip script

This information is from the tooltip page on Allakhazam. It allows you to have tooltips for Everquest, Everquest II*, Final Fantasy XI, Lord of the Rings Online, Warhammer Online and World of Warcraft.

Paid site
It would be easiest to add this line into your Banner Area (Control Panel > Custom Code > Banner HTML)

<script type="text/javascript" src="http://common.allakhazam.com/shared/akztooltip.js"></script>

*for EQ2, use this line instead:
<script type="text/javascript" src="http://common.zam.com/shared/zampower.js"></script>
Free site/Paid site
Since it appears (or maybe it's just me) that you can't get to the footer from the "Style & Colors" link anymore, it might be better to add this line into the Custom jQuery Code box (Control Panel > Custom Code > Custom JQuery). Add the code in blue into the appropriate boxes, check the Enabled box, then Save:
  • Document.Ready Event Code:
    return

  • Functions:
    </script><script type="text/javascript" src="http://common.allakhazam.com/shared/akztooltip.js">

    *for EQ2, use this line instead:

    </script><script type="text/javascript" src="http://common.zam.com/shared/zampower.js">
*WARNING* There must be code in both the "Document.Ready Event Code" and "Functions" boxes or you will get a blank page when you reload. And yes, the script in the functions box looks reversed, but that's the way to get it to work properly.

How to make the links work

The script looks for the url in the href part of the link, so make sure that the link is correct.
  • Find the item on Allakhazam that you want to link
  • Copy (Ctrl-C) the URL from the browser and paste it into your forum post or content box editor
  • Copy (Ctrl-C) the code below and paste it into your forum post or content box editor

    <a href="http://war.allakhazam.com/db/item.html?waritem=402307">Purloined Gown</a>

  • Replace the code in orange with the URL of the item you just saved
  • Replace the code in green with the name of the item
  • Save the forum post or content box data.
From here the script adds the tooltip, so there's nothing else you need to do.

Edit (2/27/2009): Updated Control Panel paths
Edit (5/22/2009): Added the new script for EQ2, since ZAM has partnered with Allakhazam
TopBottom

Draylor (New Admin) 2/25/2009 12:56 PM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
Draylor
Posts: 424
Fingers of Fury!

Mottie,
    On this, I attempted to put :
 <script type="text/javascript" src="http://common.allakhazam.com/shared/akztooltip.js"></script> In my banner HTML and enable it, but it give me an Error about (have to redo to get exact error message) not being able to locate the guild ID on guild portal and then says page can't be displayed. I attempted to put it in the footer also, with same message.

    I just used the the JQuery (not sure on difference here - not a programmer) entry for the Free site, and it worked on my pages.

    You wouldn't happend to know why the first line doesn't work off hand? I can maybe get and post a Screenshot if needed.

~Draylor
TopBottom

Mottie (MVP) 2/25/2009 2:03 PM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Hi Draylor!

I just tested adding the script into the banner & footer area and it worked fine for me. Did you add the script while in HTML mode ()?
TopBottom

Draylor (New Admin) 2/26/2009 2:58 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
Draylor
Posts: 424
Fingers of Fury!

Yes - this is what I get when putting it into the Header area:

    Internet Explorer cannot open internet site: http://www.guildportal.com/Guild.aspx?GuildID:231248&TabID:1947542 operation aborted. 
    After the above, it gives a blank webpage can't be displayed.

    When I remove the code from my banner area and uncheck enabled, it works fine. Now, not sure on this, but I still just use the banner line under Site Elements Styles - and just add the above line to my banner (Same for Footer, but don't have a footer on our page). I've done similar things on my test site (added something to footer, and enabled and it worked)

    On the footer note also, I tried it under Site Elements Sytles section also for the Footer, clicked the <> and added line of code, clicked save. When I refresh our website, it tosses up that above error.

~Draylor
TopBottom

Draylor (New Admin) 2/26/2009 3:05 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
Draylor
Posts: 424
Fingers of Fury!

Mottie,
    Actually, I may have figured this out (Although don't fully understand why it didn't work) - I noticed when looking at the Footer under Advanced Style Settings, which doesn't have the <>, that there was a required line : $block[boilerplate] - once I put this in and added the first line of code, my page opened fine & the pop up to Allakazham's site worked.

   I don't fully understand why it wouldn't work in the Banner area, as I don't see a required code, only optional. Like I was saying above though, I have my banner line in Site Element Styles > Banner - which is the 'template' area - and didn't add anything except the code for pop-up under Advanced  Style Settings. Maybe it had issues attempting to use both of them /shrug.

~Draylor 
TopBottom

Eochain (New Admin) 3/3/2009 2:32 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)

Image Blocked

Eochain
Posts: 518
Zomgawsh Poster

I get the same problem with internet explorer and using the script - I tried putting it in the footer and it still crashed - and I added the $block command at the top and then at the bottom of the footer html and still no joy

Signature blocked by Forum Admin!
TopBottom

Mottie (MVP) 3/3/2009 5:33 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Hi Eochain!

Did you try adding the script into the jQuery code box? I still have no idea why it's not working properly in the header HTML and with the new control panel change, the footer HTML isn't the same Footer area to add code - it acts weird with anything other than HTML.

*NOTE* The Footer where I told everyone to add javascript code is not accessible anymore. I've submitted a ticket about it and hopefully we'll get access to it back.... just so you all remember, that was the area that required you to add "$block[boilerplate]"
TopBottom

Eochain (New Admin) 3/14/2009 7:40 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)

Image Blocked

Eochain
Posts: 518
Zomgawsh Poster

Hi Mottie! That did it and the weird thing is that I followed the instructions for the Free Site (even though my site is paid for!! ha ha)

Not sure if you know this or not but one of the links to your pictures on Photobucket for the Guardian icon that displays in the roster tab, is pointing to a document graphic instread of the LOTRO Guardian symbol.

Thanks again for all your help


Signature blocked by Forum Admin!
TopBottom

Mottie (MVP) 3/14/2009 10:54 AM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Hi Eochain!

Thanks for pointing out that mistake! Because the misspelling of "guardian" in the icon name was bugging me, I renamed the image on photobucket, but forgot to update the forum posts LOL. Oh well, glad you caught it
TopBottom

Draylor (New Admin) 5/21/2009 6:22 PM EST : RE: Tooltips (EQ, EQ2, FFXI, LotR, WAR & WoW)
Draylor
Posts: 424
Fingers of Fury!

Mottie (and All),

    This was 'broken' for Everquest 2 players when the site changed from Allakhazam's to ZAMS - they are now using new IDs (based on SOE's DB's I believe) and the URL is different.

    I went to ZAMS site and posted and the techs responded and fixed the script ... change your script to what you currently have on sites to:

        
  
    Be sure to also use the new item IDs from ZAMS site when directing to a link ...

    In case you want to follow the thread I had on ZAMS - CLICK HERE

~DraylorOMG - I can't paste Script - WHY??? Also now my forum posts = PLAIN TEXT - how do I get it back to where I can edit!!!!!!!!!?
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%