Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > WoW Server Status Not Working
~Sarrita~ (New Admin) 5/7/2008 6:54 AM EST : WoW Server Status Not Working
~Sarrita~
Posts: 64
Posts With Wolves

For a long time now I've had a WoW server status content box on my guild's home page. However, it doesn't seem to be working anymore I got the code from this site: http://www.darkenbane.com/wow/wowservers.php

Any idea where I can get a new one?
TopBottom

Mottie (MVP) 5/7/2008 12:05 PM EST : RE: WoW Server Status Not Working
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

The Darkbane site disbanded (or something) and changed their website, so the status is no longer available. The only thing I've found so far to replace it is from this site... it provides an image, so you can't change the style

http://www.wowrealmstatus.net/
TopBottom

Mottie (MVP) 5/15/2008 8:07 PM EST : RE: WoW Server Status Not Working
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Well it looks like the darkenbane server status listings are working again, but when you go to that page, the colors are all messed up. I honestly don't know if it will stay functional, but I'm using it again because the wowrealmstatus image just looks ugly to me LOL
TopBottom

~Sarrita~ (New Admin) 5/19/2008 8:36 AM EST : RE: WoW Server Status Not Working
~Sarrita~
Posts: 64
Posts With Wolves

Thanks for your help 
TopBottom

Pentamorous (New Admin) 5/28/2008 9:28 AM EST : RE: WoW Server Status Not Working
Pentamorous
Posts: 2317
Zomgawsh Poster

An alternative...  with no graphics...    but it does force color choice.

Use the 'Embedded Page' control type, and paste this into the URL area:

http://www.rpgoutfitter.com/wow-gm-rs/realmstatus.cfm?Realm=Dragonblight-US


Well... You can replace the realm name in that link with the realm of your choice.



Now, what I really would like is to be able to get the info of the realm status into a javascript variable, then I could literally do whatever I wanted with it on the page.

(/hopes some javascripty guru reads this)

cheers!
TopBottom

Mottie (MVP) 5/28/2008 11:31 AM EST : RE: WoW Server Status Not Working
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

LOL Pentamorous,

We think alike... I only dabble in Javascript, but I tried writing something that would get the server status, but apparently you can't read XML (or RSS Feed) from a different website without certain permissions. It works great on my desktop, but when I post it I only get a "uncaught exception: Permission denied to call method XMLDocument.load" error - maybe someone out there with better knowledge of Javascript can tell me how to solve this one? hehe

I forgot to post this earlier, but it seems that tht Darkbane site still appears to work, but it showed the server as up on Tuesday morning during maintenance. So I wouldn't trust it anymore =(

On the other hand, it seems like RPG Outfitter server status is customizable. I looked at the post they have on their forums here. It looks like you can make the background, font styles and colors match your website. Sadly, the only thing you can't customize is the color of the server status "Up" or "Down" and the population colors of "Low", "Medium" and "High".

I was messing around and got this status:


* I made it extra wide to show the background texture

url of code above: http://www.rpgoutfitter.com/wow-gm-rs/realmstatus.cfm?Realm=Dragonblight-US&bgcolor=000&color=ff8000 &realm.font-size=16px&status.color=80FFFF&population.color=80FFFF&realm.font-family=times&status.font-family=courier &background=url(http://i259.photobucket.com/albums/hh311/hotwow/themes/styles/bkgd_stone1.jpg) repeat-x



You can add stuff simply by editing (green text) & adding pieces of code from below:

start with:
http://www.rpgoutfitter.com/wow-gm-rs/realmstatus.cfm?Realm=Dragonblight-US

then add these styles as you like, but there is a limit to how much you can add though:

&icon=0 0=hide, 1=show (the text will be replaced with an image)
&bgcolor=000000 background color
&color=ffffff overall text color
&background=url(http://) no-repeat background image (and repeat code if you want: no-repeat, repeat-x or repeat-y)
   
&realm.color=000000 realm font color
&realm.font-size=14px realm font size
&realm.font-family=times realm font family
&realm.font-weight=bold realm font weight: normal or bold
&realm.font-style=italic realm font style: normal or italic
   
&status.color=000000 status font color
&status.font-size=14px status font size
&status.font-family=times status font family
&status.font-weight=bold status font weight: normal or bold
&status.font-style=italic status font style: normal or italic
   
&population.color=000000 population font color
&population.font-size=14px population font size
&population.font-family=times population font family
&population.font-weight=bold population font weight: normal or bold
&population.font-style=italic population font style: normal or italic


TopBottom

Pentamorous (New Admin) 5/29/2008 6:01 AM EST : RE: WoW Server Status Not Working
Pentamorous
Posts: 2317
Zomgawsh Poster

Wow Mottie!!  That's a great find!!

Right under my nose all this time!  LOL

HEhehee, ya I hit the same problem with javascript.  But with these customization controls, it looks like I can get pretty much the exact look I'm wanting.
TopBottom

Pentamorous (New Admin) 5/30/2008 3:21 AM EST : RE: WoW Server Status Not Working
Pentamorous
Posts: 2317
Zomgawsh Poster

Ok, I've gotten a little crazy with the server status on my site. 

I saw Mottie's post above using an IFrame within in the post to demonstrate styles and fonts, etc..  And I wondered if I could use an IFrame to have a transparent server status over my site banner.

Well I did it.   Check it out here.

It's an IFrame of the RPGO server status, using a semi transparent .png files as the background, inserted in a table which has its background image set to my banner image.

Here's my code.  (well partially)

 <table style="" cellpadding="0" cellspacing="0"><tbody><tr>

<tdstyle="width: 833px; height: 152px;" align="right"background="http://www.axiomfiles.com/Files/32850/newquintbannerthin833.jpg"valign="middle"><div align="center">
   </div><table style="width: 833px; height: 152px;"bordercolor="" cellpadding="0"cellspacing="0"><tbody><tr>
        <td style="width: 220px;" align="center"><iframesrc="http://www.rpgoutfitter.com/wow-gm-rs/realmstatus.cfm?Realm=Dragonblight-US&amp;icon=1&amp;color=ffffff&amp;background=url%28http://www.axiomfiles.com/Files/32850/white20.png%29%20repeat"frameborder="0" height="35" width="150">
            </iframe><br><br></td>
       
        <td style="width: 413px;">&nbsp;</td>
       
        <td style="width: 200px;" align="center" valign="bottom"><div align="center">
            <br><br><br><div align="right"><br></div></div><div align="right">
           </div><table align="right"background="http://www.axiomfiles.com/Files/32850/white30.png"bordercolor="" cellpadding="5" cellspacing="0" height="18"width="100"><tbody><tr align="center">
           <td><font size="1"><ahref="/ContentControls/Support/FullGallery.aspx?GuildID=32850&amp;TabID=293478"><strong>ImageGallery</strong></a></font></td></tr>
            </tbody></table></td>
    </tr></tbody></table>
</td>

<td style="width: 167px; height: 152px;" valign="top">
---edit---
</td></tr></tbody></table>



I edited out the section of code that's doing the Image Gallery in the banner.  It's really a nasty cut-n-paste hack, that has to be updated manually.  And I figured it would just confuse this thread so I cut that code out.



**edit**  gaah  that one line of code has no spaces.. screwin up the formatting of the forum.
TopBottom

Mottie (MVP) 5/30/2008 4:29 AM EST : RE: WoW Server Status Not Working
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Very cool Pentamorous! I like the image gallery in the banner and the idea of putting the server status up there too!

The only problem I've found with using iframes is that Internet Explorer doesn't support transparent backgrounds. I dislike Internet Explorer soooo much LOL. Oh well. Keep up the great work! 
TopBottom

Pentamorous (New Admin) 5/30/2008 7:08 AM EST : RE: WoW Server Status Not Working
Pentamorous
Posts: 2317
Zomgawsh Poster

Dooh!

I checked IE with a transparent background in a table.  And it worked ok for my little Image Gallery link.  I just tried a few things with a table wrapping the IFrame, and no good.  IE just insists that an IFrame is not ever gonna be transparent.  (cry)

Oh well, it still readable in IE now.  Folks with better compliant browsers get a better experience on my site.  I guess that's not so bad.
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%